IP协议分析:IP协议分片机制与原理

操作环境

操作系统:Windows 10 家庭版 64位

模拟器软件:GNS3 2.1.11

模拟路由器型号:c7200

实验环境构建

按照如下拓扑图连接4台路由器并为其配置 IP 地址:

图 0 IP协议分析实验拓扑图
图 0 IP协议分析实验拓扑图

R1上IP地址的配置命令如下,其他3个路由器的配置过程参考R1上的配置进行:

R1#config terminal
R1(config)#int s1/0
R1(config-if)#ip address 192.34.1.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#int loopback0
R1(config-if)#ip address 192.34.4.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#end
R1#write
Building configuration...
[OK]
R1#

为了避免运行路由协议产生的数据包对本次实验抓取到的数据包造成干扰,所以我们在每台路由器上都配置一个静态路由:

R1上的静态路由配置:

R1(config)#ip route 192.34.2.0 255.255.255.0 192.34.1.2
R1(config)#ip route 192.34.3.0 255.255.255.0 192.34.1.2
R1(config)#ip route 192.34.5.0 255.255.255.0 192.34.1.2

R2上的静态路由配置:

R2(config)#ip route 192.34.3.0 255.255.255.0 192.34.2.2
R2(config)#ip route 192.34.4.0 255.255.255.0 192.34.1.1
R2(config)#ip route 192.34.5.0 255.255.255.0 192.34.2.2

R3上的静态路由配置:

R3(config)#ip route 192.34.1.0 255.255.255.0 192.34.2.1
R3(config)#ip route 192.34.4.0 255.255.255.0 192.34.2.1
R3(config)#ip route 192.34.5.0 255.255.255.0 192.34.3.2

R4上的静态路由配置:

R4(config)#ip route 192.34.1.0 255.255.255.0 192.34.3.1
R4(config)#ip route 192.34.2.0 255.255.255.0 192.34.3.1
R4(config)#ip route 192.34.4.0 255.255.255.0 192.34.3.1

配置完成静态路由之后,全网所有IP地址之间都可以互相ping通。

下面需要修改一下路由器各个SeXXXXX接口上的MTU最大传输单元的值。首先查看一下现在MTU值,示例命令:

show interfaces s1/0

我们可以看到s1/0这个接口上目前默认的MTU值是 1500 bytes, 如图:

图 1 默认MTU值
图 1 默认MTU值

修改接口MTU值的参考命令如下:

R2(config)#interface s1/0
R2(config-if)#ip mtu 1300

按照下表将其余的接口都修改成表中指定的MTU值:

分别在路由器R1的s1/0, R2的s1/1接口, R3的s1/2接口上开启抓包,开启抓包的方法是在相应接口所在的连线上右键点击”Start capture”, 如图:

图 2 Start capture
图 2 Start capture

数据包抓取

第一次抓包分析: R1向R5发送扩展 Ping 的 ICMP 数据包

使用扩展ping由R1上的192.34.4.1向R5上的192.34.5.1发送扩展ping命令,指定发送一个ICMP数据包,该数据包的长度为1450, 命令如下:

R1#ping
Protocol [ip]:
Target IP address: 192.34.5.1
Repeat count [5]: 1
Datagram size [100]: 1450
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 192.34.4.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 1, 1450-byte ICMP Echos to 192.34.5.1, timeout is 2 seconds:
Packet sent with a source address of 192.34.4.1
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 92/92/92 ms
R1#

第一次数据包分析

R1到R2上的数据包

荒原之梦网站 LOGO 1.0 版设计灵感与实现过程

设计灵感

该图标设计灵感产生于2018年10月15日晚上且于当晚完成制作并正式上线,这是荒原之梦第一款正式的网站图标。

主要灵感来源于2进制电子计算机的机器码和荒原之梦网站自建站之始就确立的“方正,灵动”的主题文化以及继往开来,创造新知的坚定信念。

在LOGO 1.0 版中可以看到一个抽象的英文字母”Z”和一个汉字“工”。其中英文字母”Z”源于荒原之梦网站域名”zhaokaifeng.com”的第一个字母”Z”. 而汉字“工”则如同铁路轨道中钢轨的横截面,代表着一种风雨无阻,勇于进取的精神,灵感来源于我家门前的陇海铁路。

图 0 LOGO 1.0
图 0 LOGO 1.0
继续阅读“荒原之梦网站 LOGO 1.0 版设计灵感与实现过程”

设置Windows防火墙以允许被ICMP Ping(两种配置方式)

背景与目的

Ping测试常被用于测试网络中两台主机之间是否互相连通,但是,大多数Windows操作系统(包括桌面版和服务器版)默认都是只允许ping其他主机而不允许其他主机ping自己。下面演示如何在Windows系统上开启基于ICMPv4协议的Ping.

继续阅读“设置Windows防火墙以允许被ICMP Ping(两种配置方式)”

荒原之梦IT周报第二十八期(14 October, 2018)

摘要:Chrome 69 will keep Google Cookies when you tell it to delete all cookies;Facebook公布调查进展 证实2900万用户信息遭黑客窃取;用 HTML 标记的古怪代码注释;新手应该如何学习 PHP 语言;Git 原理入门;俄罗斯飞船发射失败,幸好两名宇航员没事…

继续阅读“荒原之梦IT周报第二十八期(14 October, 2018)”

荒原之梦IT周报第二十七期(7 October, 2018)

摘要:脸书再次遭数据泄露 近5000万用户账户可能被入侵;Tesla内部服务器受感染 被用于加密货币挖矿;WinWorld:大型的废弃操作系统、软件、游戏的博物馆;Linux各发行版本及其软件包管理方法;莫言香港公开大学演讲;危险的“黎曼猜想”…

继续阅读“荒原之梦IT周报第二十七期(7 October, 2018)”