.deb软件包的安装和软件的卸载

前言:

.deb格式的软件包是Debian和Ubuntu等Linux发行版软件安装包的文件扩展名。

使用.deb格式软件安装包安装软件

命令如下:

Debian和Ubuntu上卸载软件

命令如下:

或者使用如下命令:

 

解决BackBox中Fcitx输入法中文输入状态下不显示候选词框的问题

当我们安装Fcitx输入法时默认是安装了下面这个组件的:

该组件在非KDE桌面环境下可能会使Fcitx输入法在输入中文时无法显示候选词框。

使用下面的命令移除该组件后重启操作系统即可:

注:该方法同样适用于尝试解决在Ubuntu上遇到的类似问题。

2017年BackBox5和Ubuntu16.04.1更新源

BackBox是基于Ubuntu的Linux发行版,因此,我们可以使用Ubuntu的更新源作为BackBox的更新源。
1.查看系统版本信息:
输入:

 

显示计算机及操作系统的有关信息,在回显里我们可以看到:

 

这表明我们现在使用的Linux内核是Ubuntu

另外我们还可以通过输入命令:

 

查看内核版本,运行回显如下:

 

输入:

 

可以查看当前使用的发行版的信息,回显如下:

 

因此,本文的操作环境为:
BackBox 5(基于Ubuntu16.04.1)

当然,在添加更新源时对版本的要求也不是这么绝对,一般情况下,只要更新源本身还在更新并能通过互联网访问,那么更新源就是可以使用的。

2.BackBox 5自带的更新源
BackBox 5自带的更新源均指向Ubuntu的官网地址,自带的更新源如下:

 

3.补充BackBox国内更新源:
输入:

 

使用leadpad打开更新源配置文件。
也可以输入:

 

使用vi编辑器打开更新源配置文件
注:不要忘记加上sudo

将以下更新源复制到原更新源的前面保存即可:

 

注:更改更新源之前最好先对原有的更新源做一个备份,备份命令:

 

附:
Ubuntu中文官网源列表地址

BackBox错误,无法获得锁…资源暂时不可用…无法锁定管理目录

今天准备给BackBox安装leafpad时,输入

后出现了如下的错误提示:

 

出现这种情况一般是由于apt-get进程在后台占用导致的,使用以下命令强制解锁被占用的资源:

 

之后再安装leafpad,成功安装。